[FFmpeg-trac] #349(undetermined:open): MingW32 Cross Compile of FFMPEG Fails

FFmpeg trac at avcodec.org
Fri Jul 15 23:35:32 CEST 2011

#349: MingW32 Cross Compile of FFMPEG Fails
Reporter:  jlsantiago0  |       Owner:
    Type:  defect       |      Status:  open
Priority:  important    |   Component:  undetermined
 Version:  unspecified  |  Resolution:
Keywords:               |  Blocked By:
Blocking:               |  Reproduced:  0
Analyzed:  0            |

Comment (by KSHawkEye):

 I ran into this issue after updating as well.

 I worked around it by creating the libs, and then make install (where
 previously I could make the libs after I make install).

 It seems that FFmpeg won't install if it can not find the lib files, I'm
 not sure if it's only related to the shared aspect though.

 Even if the lib.exe can not be found, and the lib files can not be
 created, I suggest that it does not break the make install. I also suggest
 that if the .lib files are made, that the .def files are not installed and
 only the .lib files are. You only need one or the other.

Ticket URL: <https://avcodec.org/trac/ffmpeg/ticket/349#comment:4>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list