[FFmpeg-trac] #1712(FFmpeg:new): Audio precision in lossless and long time to encode.

FFmpeg trac at avcodec.org
Sun Sep 2 12:57:34 CEST 2012

#1712: Audio precision in lossless and long time to encode.
             Reporter:  Danixu  |                     Type:  defect
               Status:  new     |                 Priority:  normal
            Component:  FFmpeg  |                  Version:  unspecified
             Keywords:          |               Blocked By:
             Blocking:          |  Reproduced by developer:  0
Analyzed by developer:  0       |
 Summary of the bug:
 Hi, first of all, i'm sorry for my english.
 I've tried the last ffmpeg build and i get a problem with Audio precision
 in lossless audio file, the audio is delayed about 2 seconds.
 The audio is passed to another program throught a pipe, but i know that
 the other program isn't the problem, because with a very old ffmpeg
 version (SVN 16573, Jan 13 2009) works fine, and i've tried with wav
 output without pipe and get the same problem.

 If you want, here's a test wav files:

 The command line that i've used is :
 ffmpeg_old -i "input.ape" -ss 00:59:18.71 -t 00:00:15.55 out_oldffmpeg.wav
 ffmpeg -i "input.ape" -ss 00:59:18.71 -t 00:00:15.55 out_newffmpeg.wav

 How to reproduce:
 % ffmpeg -i input -ss 00:45:25 -t 00:05:25 -ac 2 -f wav -

 The output is a pipe to another program.

 '''ffmpeg version''' N-44080-gdfb4757
 '''built on''' Aug 31 2012 16:58:51 with gcc 4.7.1 (GCC)
 configuration: --enable-gpl --enable-version3 --disable-pthreads --enable-
 ime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r --enable-
 libass -
 -enable-libcelt --enable-libopencore-amrnb --enable-libopencore-amrwb
 ibfreetype --enable-libgsm --enable-libmp3lame --enable-libnut --enable-
 peg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-
 ra --enable-libutvideo --enable-libvo-aacenc --enable-libvo-amrwbenc
 bvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid

 The other thing that i wan to answer is why the program take a long time
 to convert a portion of a file, for example:
 ffmpeg -i input.ape -ss 00:45:15.42 -t 00:00:15.25 output.wav

 the program stay a long time without do anything and then start to
 convert. I take about 2 minutes to convert 15s of audio.

Ticket URL: <https://ffmpeg.org/trac/ffmpeg/ticket/1712>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list