[FFmpeg-trac] #2447(undetermined:new): AAC encoder segfault on PPC/OS X 10.5.8

FFmpeg trac at avcodec.org
Mon Apr 22 10:56:06 CEST 2013

#2447: AAC encoder segfault on PPC/OS X 10.5.8
             Reporter:  mt      |                    Owner:
                 Type:  defect  |                   Status:  new
             Priority:  normal  |                Component:  undetermined
              Version:  1.2     |               Resolution:
             Keywords:          |               Blocked By:
             Blocking:          |  Reproduced by developer:  0
Analyzed by developer:  0       |

Comment (by mt):

 Yes, I tried --disable-pthreads. It crashed too (ffmpeg emulated the
 threads when running).
 Even cleaned out the dust and ran the apple hardware test to check the
 hardware, no problen found.
 Compiled gcc 4.7 via macports to check with a newer compiler, same crash
 with that binary.

 Just tried some older binaries 0.11, 1.0 and 1.1/1.1.1.
 0.11 and 1.0 work ok, 1.1 and above crahes.

 To rule out a thermal problem I tried to start up with only one cpu (nvram
 boot-args="cpus=1"), but then the machine shutdowns down on booting.
 Maybe a faulty cpu? Not sure though.
 Running hardware test right now again.
 I will let it cool off for some time and then try to boot again.

Ticket URL: <https://ffmpeg.org/trac/ffmpeg/ticket/2447#comment:15>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list