[FFmpeg-trac] #3117(avformat:open): stream extraction broken after ffmpeg 2.0.2 when using libbluray

FFmpeg trac at avcodec.org
Thu Nov 14 22:46:05 CET 2013

#3117: stream extraction broken after ffmpeg 2.0.2 when using libbluray
             Reporter:  Selur        |                    Owner:
                 Type:  defect       |                   Status:  open
             Priority:  important    |                Component:  avformat
              Version:  git-master   |               Resolution:
             Keywords:  libbluray    |               Blocked By:
  mpegts regression                  |  Reproduced by developer:  0
             Blocking:               |
Analyzed by developer:  0            |

Comment (by Selur):

 Yes, I did.
 First another user (which used a ffmpeg version build by me) complained
 that my version seems to be broken and the old one (build by me half a
 year ago) he used worked fine.
 Since I could reproduce the problem with the x264 Demo Blu-ray and with
 another TestDisk I got, I then build ffmpeg with an older libbluray
 version to check if this was a libbluray problem. Since going back to an
 older libbluray version didn't help I started checking zeranoes builds and
 realized that the 2.0.2 build from his site was the first (by build date;
 didn't know that this was was out of order) which worked again.
 I then also tested a few other disks and since the x264 Demo was the only
 one I know of which is freely available I reported using that one.
 -> the problem happens for me with every disk

Ticket URL: <https://ffmpeg.org/trac/ffmpeg/ticket/3117#comment:32>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list