[FFmpeg-trac] #3256(avformat:closed): FFMPEG SVQ3 Matroska remux produces unplayable output (FFPlay don't want to play SVQ3 MKV output)

FFmpeg trac at avcodec.org
Mon Mar 17 02:09:12 CET 2014

#3256: FFMPEG SVQ3 Matroska remux produces unplayable output (FFPlay don't want to
play SVQ3 MKV output)
             Reporter:  Vika         |                    Owner:
  Apelsinova                         |                   Status:  closed
                 Type:  defect       |                Component:  avformat
             Priority:  important    |               Resolution:  fixed
              Version:  git-master   |               Blocked By:
             Keywords:  mkv svq3     |  Reproduced by developer:  1
  regression                         |
             Blocking:               |
Analyzed by developer:  1            |
Changes (by michael):

 * cc: michael (added)
 * status:  open => closed
 * resolution:   => fixed


 Replying to [comment:15 michael]:
 > Replying to [comment:9 Vika Apelsinova]:
 > > > ffplay can now play the video from output-mkvtoolnix-6.6.0.mkv
 > >
 > > Why only video?
 > Which tool or player can play the audio ?
 > If nothing can play it, then most likely the issue is with the file
 > >
 > > Ok, everything is clear with FFPlay (decoding). What with encoding?
 > >
 > > The output file is still invalid?
 > >
 > > Why FFMPEG's output uses deprecated "A_QUICKTIME/QDM2" as Audio Codec
 ID insted of just "A_QUICKTIME" like mosu wrote?
 > Which application/player supports A_QUICKTIME?
 > mosu said vlc does not and if i understood correctly the spec did not
 list A_QUICKTIME either.
 > FFmpeg should create files that can be played by most
 players/applications. We also should conform to the spec. If from 2
 revissions of the spec one works with many players and one with few, we
 should prefer the one that works with many.
 > Dont hesitate to correct me if one of my assumtations is wrong

 just tried to replace A_QUICKTIME/QDM2 by A_QUICKTIME, but the resulting
 file cannot be played by any player i tried. So its not that simple
 Also please open a seperate ticket for the QDM2 issue, this one is about
 SVQ3 remux not playing in ffplay (which is fixed thus closing it)
 dont hesitate to reopen this ticket if svq3 isnt fixed, but please lets
 move qdm2 to a seperate ticket, so as to keep things easy to manage as
 these are 2 seperate issues

Ticket URL: <https://trac.ffmpeg.org/ticket/3256#comment:16>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list