[FFmpeg-trac] #1304(avformat:reopened): rawvideo 8bpp: incorrect output with -vcodec copy

FFmpeg trac at avcodec.org
Wed Sep 24 15:56:27 CEST 2014

#1304: rawvideo 8bpp: incorrect output with -vcodec copy
             Reporter:  ami_stuff   |                    Owner:
                 Type:  defect      |                   Status:  reopened
             Priority:  normal      |                Component:  avformat
              Version:  git-master  |               Resolution:
             Keywords:  pal8        |               Blocked By:
             Blocking:              |  Reproduced by developer:  1
Analyzed by developer:  1           |

Comment (by benoit):

 I tried to not use 'copy' as a codec, but it also fails to play (ffplay
 has wrong display and WMP just refuses to open the file).
 I also tried to create a non odd sized video , but WMP refuses to play it
 as well (using {{{ffmpeg -f lavfi -t 5 -i testsrc -c:v rawvideo -pix_fmt
 pal8 -y out.avi}}}) whereas it's OK for ffplay.
 I'll try to dig a bit more to see what's different between None_8bpp.avi
 and the file we generate.

Ticket URL: <https://trac.ffmpeg.org/ticket/1304#comment:8>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list