[FFmpeg-trac] #3974(undetermined:new): ffplay crashing with some resolutions in linux terminal

FFmpeg trac at avcodec.org
Thu Sep 25 07:04:46 CEST 2014

#3974: ffplay crashing with some resolutions in linux terminal
             Reporter:  setup32      |                     Type:  defect
               Status:  new          |                 Priority:  normal
            Component:               |                  Version:
  undetermined                       |  unspecified
             Keywords:  ffplay       |               Blocked By:
  linux terminal console             |  Reproduced by developer:  0
             Blocking:               |
Analyzed by developer:  0            |
 im new to linux.
 im trying to play a video in a terminal (not in x) with ffplay.
 the os is debian wheezy 7.6.0.
 i installed all the ffmpeg dependencies on the debian compile guide
 libgpac-dev was not in the apt-get package management so i skipped it.
 i tried to play using ffplay version 2.4 and 2.3.3.
 i compiled ffmpeg/ffplay source code with no extra options like --enable-
 im logged in as root.
 i tried this with mpeg4 native and wmv1 native codecs and both avi mpg
 i always set -aspect 4:3.
 tried with my integrated intel graphics and radeon 9250.

 ./ffplay -x 200 -y 200 -i inputvideo.avi

 ffplayer crashes with "Segmentation Faultn" in terminal when a videos
 width or height (-s widthxheight) is a multiple of 80 eg. 640x480 320x240
 160x120 480x640.
 some dimensions dont crash but show a tiny green strip motion picture but
 the input video isnt green (size is maybe 10x2) and full screen doesnt fix

 ffplay plays all videos i tried perfectly in X (xdm and gdm3).
 plays videos perfectly in the terminal with weird dimensions like 318x240
 and 638x480 and most/all with no multiples of 80.

 segmentation Faultn fd= blah blah blah

Ticket URL: <https://trac.ffmpeg.org/ticket/3974>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list