[FFmpeg-trac] #4379(undetermined:new): paket loss iwth rtp via udp

FFmpeg trac at avcodec.org
Fri Mar 20 07:20:51 CET 2015

#4379: paket loss iwth rtp via udp
             Reporter:               |                     Type:  defect
  richard_wang                       |                 Priority:  normal
               Status:  new          |                  Version:
            Component:               |  unspecified
  undetermined                       |               Blocked By:
             Keywords:  rtp via udp  |  Reproduced by developer:  0
  packet loss                        |
             Blocking:               |
Analyzed by developer:  0            |
 Summary of the bug:
 When I use udp for rtp communication, I got lot of "rtp: missed packet",
 and the video output is full of mosaic.

 How to reproduce:
 With ffmpeg-2.3, I work with VLC as rtsp server. Stream a mp4 file through
 rtsp without transcoding. On the client side, try below command:
 ffplay "rtsp://"

 The can see the sympton.

 I tried to search in the forum, and found it similar to #258, #257, and
 #285. But even I tried to disable inside udp.c HAVE_PTHREAD_CANCEL, it
 does not help.

 Thanks in advance for any suggestion.

 % ffmpeg -i input ... output
 ffmpeg version
 built on ...
 Patches should be submitted to the ffmpeg-devel mailing list and not this
 bug tracker.

Ticket URL: <https://trac.ffmpeg.org/ticket/4379>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list