[FFmpeg-trac] #4831(avcodec:reopened): Can't initialize h264_qsv encoder post Aug 29 2015 - Ivy Bridge CPU

FFmpeg trac at avcodec.org
Tue Sep 22 11:41:00 CEST 2015

#4831: Can't initialize h264_qsv encoder post Aug 29 2015 - Ivy Bridge CPU
             Reporter:  babgvant     |                    Owner:  IvUs
                 Type:  defect       |                   Status:  reopened
             Priority:  important    |                Component:  avcodec
              Version:  git-master   |               Resolution:
             Keywords:  qsv          |               Blocked By:
  regression                         |  Reproduced by developer:  0
             Blocking:               |
Analyzed by developer:  1            |

Comment (by babgvant):

 Replying to [comment:24 heleppkes]:
 > We request 1.9, and you have 1.11, and it still doesn't work? How odd.
 > Maybe some of the features we use are actually higher in the API?
 LookAhead requires HW support on top of API support - if its the default
 now, that might be a problem.

 Generally the min version is intended to act just as an application
 baseline. If you configure features that require a higher version than is
 available then the encoder will fail to init.

 There are two ways I can think of to approach this:

 1) Set the min version to 1.1 then use the actual queried version to only
 configure options that are available at the client's version (pretty easy
 with if statements and the SDK docs), reporting via the log or console
 that a feature that was requested could not be enabled if it was
 explicitly set by the user. This is the approach I use in my app, I think
 it is the most approachable and allows for better application specific
 defaults (i.e. overriding MSDK defaults with mine).

 2) Determine the min version required based on the features requested by
 the user (i.e. if they specify lookahead set the minor version to the
 appropriate level) and allow the session to fail init if it can't be met.

 I'm not aware of any applications that use 2.

 > How would one detect HW compat with LA at runtime?

 The queried version + SDK documentation (1.7 for basic LA, 1.8+ for more).

Ticket URL: <https://trac.ffmpeg.org/ticket/4831#comment:25>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list