[FFmpeg-trac] #5170(ffmpeg:open): Input option -r has no effect with -vcodec copy

FFmpeg trac at avcodec.org
Sun Jan 24 22:30:10 CET 2016

#5170: Input option -r has no effect with -vcodec copy
             Reporter:  zhangweiwu   |                    Owner:
                 Type:  enhancement  |                   Status:  open
             Priority:  wish         |                Component:  ffmpeg
              Version:  git-master   |               Resolution:
             Keywords:  fps          |               Blocked By:
             Blocking:               |  Reproduced by developer:  1
Analyzed by developer:  0            |

Comment (by Misaki):

 The -r option (for input methods) is not appropriate for variable-frame-
 rate video.

 If the documented -time_base option worked, this would fix the problem.

  ffmpeg -i "$in" -time_base 1 -f null -

 Unrecognized option 'time_base'.
 Error splitting the argument list: Option not found

 (As an input option, the same error.)

 From help pages:

        time_base rational number
            Set codec time base.

            It is the fundamental unit of time (in seconds) in terms of
 which frame
            timestamps are represented. For fixed-fps content, timebase
 should be "1
            / frame_rate" and timestamp increments should be identically 1.

 When concatenating files, if they have different time bases, the later
 files will be sped or or slowed down. Unfortunately, this can't be used to
 accomplish the objective as there's no way to reliably set the timebase
 for an output file; it's some complicated result of the frame rate.

 So if one file says it has "15360 tbn", and you want to slow it by 1/25,
 there's no way (for the typical user) to produce a file with "14746 tbn"
 (which is close to 15360*24/25=14745.6).

Ticket URL: <https://trac.ffmpeg.org/ticket/5170#comment:4>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list