[FFmpeg-trac] #5536(ffmpeg:new): Segmentation fault (core dumped) on large file

FFmpeg trac at avcodec.org
Tue May 10 22:57:55 CEST 2016

#5536: Segmentation fault (core dumped) on large file
             Reporter:  Sap1ens      |                     Type:  defect
               Status:  new          |                 Priority:  normal
            Component:  ffmpeg       |                  Version:  git-
             Keywords:  large        |  master
  images, mp4, libx265, HEVC         |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
 I am using ffmpeg to compress some big images (about 3500 3000x8000 .tiff
 files) and I am using this command:
 ffmpeg -y -framerate 30 -start_number 13244 -i sources/full/full_0%03d.tif
 -c:v libx265 -r 30 -x265-params crf=22 -pix_fmt yuv420p
 When I run it on small sets of small images, it works just fine, but on
 the big images it crashes after a few frames with messages like
 Segmentation fault (core dumped)      0kB time=00:00:00.00 bitrate=N/A
 speed=   0x
 I tried compressing fewer files, but it still segfaults. I don't think
 that it is a memory problem, since I have 96 GB of RAM and the same amount
 of swap. Also I tried again the command on the smaller sets and it keeps
 going just fine.
 I am running Ubuntu 14.04.4 LTS (school property, I don't have sudo
 privileges) and using the static build.
 I have included a log file generated with -report, please tell me if you
 need anything else.
 Also, I just noticed that H.264 encoding through libx264 does not run into
 the problem, still I would need HEVC encoding if possible.
 Thank you in advance,

Ticket URL: <https://trac.ffmpeg.org/ticket/5536>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list