[FFmpeg-trac] #386(undetermined:closed): Missing audio and subtitle streams in vob file

FFmpeg trac at avcodec.org
Thu Jan 19 12:32:40 EET 2017

#386: Missing audio and subtitle streams in vob file
             Reporter:  Aztek        |                    Owner:
                 Type:  defect       |                   Status:  closed
             Priority:  normal       |                Component:
              Version:  unspecified  |  undetermined
             Keywords:  mpegps       |               Resolution:
             Blocking:               |  needs_more_info
Analyzed by developer:  0            |               Blocked By:
                                     |  Reproduced by developer:  0

Comment (by antlarr):

 Just wanted to add that I encountered such a vob file too. In my case
 ffmpeg -i VTS_01_1.VOB says the file contains:
  1 data track (dvd_nav_packet), 1 video track, 5 audio tracks and 17
 subtitle tracks
 while mediainfo says it contains:
  1 video track and 5 audio tracks (same as ffmpeg) but 25 subtitle tracks.
 When trying to check the tracks of VTS_01_2.VOB (or 3, 4 or 5), ffmpeg
 identified all 25 subtitle tracks just like mediainfo did.

 As a curious note, I tried doing:
  cat VTS_01_1.VOB VTS_01_2.VOB  VTS_01_3.VOB  VTS_01_4.VOB  VTS_01_5.VOB >
  ffmpeg -i full.vob
 And then ffmpeg only showed 1 data track, 1 video track and 5 audio tracks
 (that is, everything except any subtitle tracks).

 I was about to report a bug when I noticed this old one that was closed 4
 years ago with "needs_more_info" and the request to test with "-probesize
 2G -analyzeduration 2G". So I tried that and it fixed the problem for me,
 so it probably also fixed it to the original reporter.

 When doing:
  ffmpeg -probesize 1G -analyzeduration 1G -i VTS_01_1.VOB
 I got all expected data, video and audio tracks, and instead of 25
 subtitle tracks I got 29 subtitle tracks. Even more than expected :).
 I tried with the concatenated zzz.vob file and the 29 subtitle tracks were
 recognized there too.

 Btw, I tested with different sizes and for example, with -probesize 400M
 -analyzeduration 400M, ffmpeg recognized 28 subtitle tracks, with 100M, 27
 tracks and with 80M, only 4 tracks.

 So, the problem was solved with those options. Anyway, if you still want a
 sample I can provide it.

Ticket URL: <https://trac.ffmpeg.org/ticket/386#comment:26>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list