[FFmpeg-trac] #6553(undetermined:new): Memory leak when copyts option enabled on udp input

FFmpeg trac at avcodec.org
Wed Jul 26 09:05:11 EEST 2017

#6553: Memory leak when copyts option enabled on udp input
             Reporter:  krs_vital    |                     Type:  defect
               Status:  new          |                 Priority:  normal
            Component:               |                  Version:
  undetermined                       |  unspecified
             Keywords:               |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
 ffmpeg command:

 /usr/local/bin/ffmpeg -copyts -start_at_zero -vsync 0 -copytb 1
 -overrun_nonfatal 1 -i udp:// -sn -dn -vcodec copy
 -acodec aac -hls_allow_cache 0 -hls_ts_options pcr_period=0 -hls_base_url
 /ts/SPAS/ -hls_list_size 5 -hls_time 5 -hls_flags
 delete_segments+omit_endlist -map 0 -vsync 0 -ignore_unknown -strict -2
 -use_localtime 1 -hls_segment_filename /hls/ts/SPAS/stream_%s.ts

 check proc memory command:

 ps axo %mem,comm,pid | grep ffmpeg | sort -nr | head -n 10
 0.2 ffmpeg 989

 leak up to 200 Mb

 if I run more than 50 processes, I have to make sure that ffmpeg eating
 all the memory and I automatically restart a process if it eats more than
 200 Mb but if I run ffmpeg without the option copyts, on some channels I
 have just lost the sound and I still have to restart the process, but
 manually, because visible is no problem, memory does not leak

Ticket URL: <https://trac.ffmpeg.org/ticket/6553>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list