[FFmpeg-trac] #6406(undetermined:new): Framerate issues with HVEC and mkv container

FFmpeg trac at avcodec.org
Sat May 20 10:37:35 EEST 2017

#6406: Framerate issues with HVEC and mkv container
             Reporter:  aLPHa_NRG    |                     Type:  defect
               Status:  new          |                 Priority:  normal
            Component:               |                  Version:
  undetermined                       |  unspecified
             Keywords:               |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
 Summary of the bug:
 Similar to ticket: https://trac.ffmpeg.org/ticket/259

 The issue is that FFMPEG does not detect the right framerate. My mkv file
 is 4k and i want to downscale the video to 1920 x1080 full HD. FFMPEG
 detects the framerate as 29.98 while this needs to be 29.986.

 I have been looking at the source but I cant seem to figure out where the
 framerate detection is. To me it means your floats are capped to 2
 decimals or something or the framerate is not detected properly with x265
 lib I dunno...

 How to reproduce:
 % ffmpeg -i input.mkv
 Stream #0.0: Video: vc1 (Advanced), yuv420p, 3840x2160 [PAR 1:1 DAR 16:9],
 29.98 fps, 29.98 tbr, 1k tbn, 29.98 tbc (default)

 ffmpeg version: tried two versions both gave the same error. latest from
 ubuntu 16.04 (yesterday) and pulled latest source through git yesterday
 and compiled it)

 built on:
 Ubuntu 16.04

 I wil update the ticket monday with more info

Ticket URL: <https://trac.ffmpeg.org/ticket/6406>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list