[FFmpeg-trac] #7276(undetermined:new): Transcoding gives unplayable file, but not always.

FFmpeg trac at avcodec.org
Mon Jun 25 19:43:37 EEST 2018


#7276: Transcoding gives unplayable file, but not always.
-------------------------------------+-------------------------------------
             Reporter:  virtualpaul  |                     Type:  defect
               Status:  new          |                 Priority:  normal
            Component:               |                  Version:
  undetermined                       |  unspecified
             Keywords:               |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
-------------------------------------+-------------------------------------
 Summary of the bug:
 Trans-coding video.ts (from OTA recording) to video.mp4 works most of the
 time but it does not always work.

 When it does not work, I checked that the video.ts plays fine but the
 resulting video.mp4 won't play in either VLC or Windows media player.
    In VLC, I got this error:
       avcodec error: Could not open video.mp4: Unknown error
    In WMP:
       Windows Media Player encountered a problem while playing the file.

 Perhaps a setting I am using is incompatible with another setting?

 Not sure if it is related but it seems to happen mostly on larger files
 (movies) and not on smaller files (episodes).
 So I cannot really upload a small file for you to check.

 I tried cutting down a large file but ffmpeg returns this error:
 [... @ ] moov atom not found video.mp4: invalid data found when processing
 input

 How to reproduce:
 {{{
 "\ffmpeg-3.4.2-win64-static\bin\ffmpeg.exe" -i video.ts -i video_meta.txt
 -map_metadata 1 -vcodec libx264 -profile:v high -level:v 4.1 -crf 18
 video.mp4

 ffmpeg version 3.4.2 windows 64 bit
 }}}

--
Ticket URL: <https://trac.ffmpeg.org/ticket/7276>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker


More information about the FFmpeg-trac mailing list