[FFmpeg-trac] #7393(undetermined:new): FeatureRequest: unify strftime/use_strftime

FFmpeg trac at avcodec.org
Sun Sep 2 14:36:12 EEST 2018

#7393: FeatureRequest: unify strftime/use_strftime
             Reporter:  jesusch      |                     Type:
               Status:  new          |  enhancement
            Component:               |                 Priority:  normal
  undetermined                       |                  Version:
             Keywords:  hls,segment  |  unspecified
             Blocking:               |               Blocked By:
Analyzed by developer:  0            |  Reproduced by developer:  0
 Currently hls and segment demuxer have the same functionality with
 different parameter names

 hls: -strftime bool
 segment: -use_strftime bool

 basically both do the same, so I think they should be named both in the
 same way?

 Additionally there is a parameter called which only exists for hls demuxer

 -use_strftime_mkdir bool

 Would be nice to have the same functionallity for segment demuxer as well
 (and again using the same syntax

 I'd vote for both muxers using the short_name (-strftime[_mkdir])

 Unfortunatelly I have no clue about C but also in terms of codebase they
 could use the same code fragments?

Ticket URL: <https://trac.ffmpeg.org/ticket/7393>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list