[FFmpeg-trac] #8432(undetermined:new): Invalid manifest created by dash muxer output

FFmpeg trac at avcodec.org
Wed Dec 18 23:36:19 EET 2019

#8432: Invalid manifest created by dash muxer output
             Reporter:  pcgeek86     |                     Type:  defect
               Status:  new          |                 Priority:  normal
            Component:               |                  Version:
  undetermined                       |  unspecified
             Keywords:  dash,        |               Blocked By:
  streaming                          |
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
 '''Summary of the bug''':

 I am using ffmpeg to ingest an rtsp stream, and emit it as a DASH / x264
 stream written onto the filesystem. The following files are emitted onto
 the filesystem. When I attempt to open the .mpd DASH manifest file with
 VLC or ffplay, the stream will not play. Instead, I get an error message
 from ffplay: "Invalid data found when processing input"

 This issue was also posted here (not by me):

 I have tried using the latest snapshot of ffmpeg, and have tried many
 different permutations of my ffmpeg command, but I always receive the same
 resulting behavior ... the DASH manifest will not playback in ffplay or

 chunk-stream0-00001.m4s     chunk-stream0-00005.m4s     chunk-
 stream0-00009.m4s     chunk-stream0-00013.m4s     chunk-stream0-00017.m4s
 chunk-stream0-00021.m4s     chunk-stream0-00025.m4s     init-stream0.m4s
 chunk-stream0-00002.m4s     chunk-stream0-00006.m4s     chunk-
 stream0-00010.m4s     chunk-stream0-00014.m4s     chunk-stream0-00018.m4s
 chunk-stream0-00022.m4s     chunk-stream0-00026.m4s     manifest.mdp
 chunk-stream0-00003.m4s     chunk-stream0-00007.m4s     chunk-
 stream0-00011.m4s     chunk-stream0-00015.m4s     chunk-stream0-00019.m4s
 chunk-stream0-00023.m4s     chunk-stream0-00027.m4s
 chunk-stream0-00004.m4s     chunk-stream0-00008.m4s     chunk-
 stream0-00012.m4s     chunk-stream0-00016.m4s     chunk-stream0-00020.m4s
 chunk-stream0-00024.m4s     chunk-stream0-00028.m4s.tmp

 How to reproduce:

 mkdir ~/Video
 ~/Downloads/ffmpeg -rtsp_transport tcp -i
 rtsp://username:password@ -an -filter:v fps=fps=5 -f dash
 -remove_at_exit 1 ~/Video/manifest.mdp

 ffmpeg version N-96084-gefefba61f8-tessus  https://evermeet.cx/ffmpeg/
 Copyright (c) 2000-2019 the FFmpeg developers
   built with Apple clang version 11.0.0 (clang-1100.0.33.16)
   configuration: --cc=/usr/bin/clang --prefix=/opt/ffmpeg --extra-
 version=tessus --enable-avisynth --enable-fontconfig --enable-gpl
 --enable-libaom --enable-libass --enable-libbluray --enable-libdav1d
 --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-
 libmp3lame --enable-libmysofa --enable-libopencore-amrnb --enable-
 libopencore-amrwb --enable-libopenh264 --enable-libopenjpeg --enable-
 libopus --enable-librubberband --enable-libshine --enable-libsnappy
 --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame
 --enable-libvidstab --enable-libvmaf --enable-libvo-amrwbenc --enable-
 libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-
 libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-
 libzimg --enable-libzmq --enable-libzvbi --enable-version3 --pkg-config-
 flags=--static --disable-ffplay
   libavutil      56. 36.101 / 56. 36.101
   libavcodec     58. 65.100 / 58. 65.100
   libavformat    58. 35.101 / 58. 35.101
   libavdevice    58.  9.101 / 58.  9.101
   libavfilter     7. 69.101 /  7. 69.101
   libswscale      5.  6.100 /  5.  6.100
   libswresample   3.  6.100 /  3.  6.100
   libpostproc    55.  6.100 / 55.  6.100
 Hyper fast Audio and Video encoder
 usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options]

 built on ... MacOS
 Patches should be submitted to the ffmpeg-devel mailing list and not this
 bug tracker.

Ticket URL: <https://trac.ffmpeg.org/ticket/8432>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list