[FFmpeg-trac] #7650(avcodec:closed): FFmpeg MPEG-2 encode fails to "invalid RC mode" when iHD driver is used through VA-API instead of QSV

FFmpeg trac at avcodec.org
Wed Feb 27 11:23:55 EET 2019

#7650: FFmpeg MPEG-2 encode fails to "invalid RC mode" when iHD driver is used
through VA-API instead of QSV
             Reporter:  eero-t       |                    Owner:
                 Type:  defect       |                   Status:  closed
             Priority:  normal       |                Component:  avcodec
              Version:  unspecified  |               Resolution:  fixed
             Keywords:  vaapi        |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |

Comment (by eero-t):

 Verified, I don't anymore get the same error and everything works now
 using QSV & VA-API backends with '''iHD''' driver on GEN9+ '''Core'''

 On BXT / APL devices I get now following error:
 ffmpeg version N-93252-gf948082e5f Copyright (c) 2000-2019 the FFmpeg
 [AVHWDeviceContext @ 0x555a5dcbb6c0] Initialised VAAPI connection: version
 [AVHWDeviceContext @ 0x555a5dcbb6c0] VAAPI driver: Intel iHD driver -
 [AVHWDeviceContext @ 0x555a5dcbb6c0] Driver not found in known nonstandard
 list, using standard behaviour.
 [h264 @ 0x555a5dcf64c0] Reinit context to 720x480, pix_fmt: yuv420p
 [h264 @ 0x555a5dcf54c0] max_analyze_duration 500000 reached at 500000
 microseconds st:0
 Input #0, h264, from '720x480p_30.00_4mb_h264_cabac_180s.264':
   Duration: N/A, bitrate: N/A
     Stream #0:0: Video: h264 (High), 1 reference frame, yuv420p(tv,
 smpte170m, progressive, left), 720x480 [SAR 10:11 DAR 15:11], 30 fps, 30
 tbr, 1200k tbn, 60 tbc
 Stream mapping:
   Stream #0:0 -> #0:0 (h264 (native) -> mpeg2video (mpeg2_vaapi))
 Press [q] to stop, [?] for help
 [h264 @ 0x555a5dcf9c80] Reinit context to 720x480, pix_fmt: vaapi_vld
 [graph 0 input from stream 0:0 @ 0x555a5dd30300] w:720 h:480
 pixfmt:vaapi_vld tb:1/1200000 fr:30/1 sar:10/11 sws_param:flags=2
 [mpeg2_vaapi @ 0x555a5dd1ba40] Input surface format is nv12.
 [mpeg2_vaapi @ 0x555a5dd1ba40] Using VAAPI profile VAProfileMPEG2Main (1).
 [mpeg2_vaapi @ 0x555a5dd1ba40] No usable encoding entrypoint found for
 profile VAProfileMPEG2Main (1).
 Error initializing output stream 0:0 -- Error while opening encoder for
 output stream #0:0 - maybe incorrect parameters such as bit_rate, rate,
 width or height

 And following with the '''i965''' VA driver on all other devices:
 [mpeg2_vaapi @ 0x55613f89e700] Driver does not support any RC mode
 compatible with selected options (supported modes: CQP).

 Should I file separate ticket(s) for these?  (Where?)

Ticket URL: <https://trac.ffmpeg.org/ticket/7650#comment:10>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list