[FFmpeg-trac] #7790(build system:closed): Endianness detection breaks when LTO is enabled through means other than the ffmpeg --enable-lto option

FFmpeg trac at avcodec.org
Fri Mar 15 01:46:31 EET 2019


#7790: Endianness detection breaks when LTO is enabled through means other than
the ffmpeg --enable-lto option
-------------------------------------+-------------------------------------
             Reporter:  RedDwarf82   |                    Owner:
                 Type:  enhancement  |                   Status:  closed
             Priority:  normal       |                Component:  build
                                     |  system
              Version:  unspecified  |               Resolution:  invalid
             Keywords:               |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
-------------------------------------+-------------------------------------
Changes (by cehoyos):

 * status:  reopened => closed
 * resolution:   => invalid


Comment:

 Replying to [comment:7 RedDwarf82]:
 > {{{
 > $ CFLAGS='-flto' ../configure --enable-cross-compile --cross-prefix
 =mips-linux- --target-os=linux --arch=mips --cpu=74kc --disable-all
 --enable-lto
 > }}}
 Thank you for the explanation!
 CFLAGS (and `--extra-cflags`) can make the configure line invalid, in
 general this cannot be detected so it makes little sense to detect it in
 some exceptional cases.

--
Ticket URL: <https://trac.ffmpeg.org/ticket/7790#comment:8>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker


More information about the FFmpeg-trac mailing list