[FFmpeg-trac] #7950(undetermined:reopened): Decode error with skip_frame set and a specific file

FFmpeg trac at avcodec.org
Wed Nov 20 00:00:27 EET 2019

#7950: Decode error with skip_frame set and a specific file
             Reporter:  ocrosoft     |                    Owner:
                 Type:  defect       |                   Status:  reopened
             Priority:  normal       |                Component:
                                     |  undetermined
              Version:  unspecified  |               Resolution:
             Keywords:               |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
Changes (by Balling):

 * status:  closed => reopened
 * resolution:  invalid =>


 Replying to [comment:3 cehoyos]:
 > Replying to [comment:2 ocrosoft]:
 > > ffplay can't play this video with "nonref" arg on my PC
 > You can use `ffplay -an -noframedrop` to test, it should also work with
 `ffmpeg -f opengl`.

 So, this just does not work. I tried to re encode with nvenc in hevc in
 MPEG TS a film (with -bf 0). https://drive.google.com/file/d

 First: note that
 http://andytather.co.uk/panda/Files/Video/HDR/LG%20Chess%20HDR.mp4 is NOT
 mp4. It is MPEG TS.

 Second: the problem with TS is persistent. I tried to encode that MPEG TS
 in mp4 and in mkv with just  "-acodec copy -vcodec copy" and it became
 good, then I again "-acodec copy -vcodec copy" back to ts and it was again
 broken. So this is very strange, also broken for VLC and Media Player
 Classic (with LAV)... But good in Potplayer and "Movies and TV"...

Ticket URL: <https://trac.ffmpeg.org/ticket/7950#comment:4>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list