[FFmpeg-trac] #9811(avfilter:new): filter 'zscale=transfer=linear' fails with "code 2050: active window must be positive"

FFmpeg trac at avcodec.org
Tue Jun 14 04:08:34 EEST 2022

#9811: filter 'zscale=transfer=linear' fails with "code 2050: active window must
be positive"
             Reporter:  rminnema     |                    Owner:  (none)
                 Type:  defect       |                   Status:  new
             Priority:  normal       |                Component:  avfilter
              Version:  git-master   |               Resolution:
             Keywords:               |               Blocked By:
  zimg,zscale,transfer               |
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
Comment (by bokeron2020):

 Chiming in to add a weird situation I'm finding and that seems maybe
 related to this bug report.

 I use a customized Windows 10 x64 install (stripped down). FFMPEG has
 worked flawlessly here for years. Relatively recent versions, about a
 month old, still worked OK but newer ones are giving me this problem:

 Some files are throwing out this same zscale error code 2050. The
 difference is I'm just using zscale as a image resizer. And now the weird

 - It only happens in my modified Windows. In a vanilla one no error is
 - It only happnes with these files. Every other file, format and codec
 I've used works OK.

 Though the file may be malformed, it's looking like some recent changes in
 zimg lib are making it behave differently... and in my case apparently
 requiring a component in Widows that my install doesn't posses. In other
 case may be causing this bug being reported.

 I've uploaded a sample file here [it will last online a month, host
 limitation] in case someone find it helpful.

Ticket URL: <https://trac.ffmpeg.org/ticket/9811#comment:4>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list