[FFmpeg-user] No accelerated colorspace conversion found from yuv422p to rgb24

Ronny Bismark tum.bismark at gmail.com
Sun Dec 23 21:48:54 CET 2012

2012/12/20 Carl Eugen Hoyos <cehoyos at ag.or.at>

> Ronny Bismark <tum.bismark <at> gmail.com> writes:
> > I already installed ffmpeg 3 times ( ffmpeg-0.10.6,
> This is old and if you are a user, there is not reason
> for you to use it.
> > ffmpeg-0.6.2 & ffmpeg-0.6.6 ) without changes.
> These are antique and known to broken.
> Please test current git head, and please test ffmpeg
> (the application). If the problem is reproducible
> with ffmpeg, please post both your command line and
> your complete, uncut console output.

> Please understand that the warning you quote is
> completely unrelated to usb, v4l and mjpeg and does
> not affect the decoding at all (it minimally affects
> the speed - not the outcome - of colourspace
> conversion).
> > Bug report #143
> > https://ffmpeg.org/trac/ffmpeg/ticket/143?cversion=0&cnum_hist=12
> At least this one looks completely unrelated.
> Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

>Please understand that the warning you quote is
>completely unrelated to usb, v4l and mjpeg and does
>not affect the decoding at all (it minimally affects
>the speed - not the outcome - of colourspace
>cd conversion).

Thats exactly the point. I can get images and they don't have any downsides
quality wise. But the pandaboard is not a powerful computer and I would
like to get rid of the webcam lag respectively get a boost in
the framerate.

I tried now the actual ffmpeg version (1.0.1 Angel) and OpenCV2.3.1
compiles with some changes ( see for bug report
http://code.opencv.org/issues/1605 ). Unfortunately, is my usb_camera
package not working anymore.
Therefore I tried to run the ffmpeg standalone application with the
following command " $ ffmpeg -an -f video4linux2 -vcodec mjpeg -s 640x480
-r 5 -b 200000 -i /dev/video3 test.avi"

Which gives me following output and then dies:

ffmpeg version git-2012-12-20-9321e93 Copyright (c) 2000-2012 the FFmpeg
  built on Dec 20 2012 13:57:12 with gcc 4.6.1 (Ubuntu/Linaro
  configuration: --enable-gpl --enable-version3 --enable-nonfree
--enable-libvpx --enable-postproc --enable-libmp3lame
--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora
--enable-libvorbis --enable-libx264 --enable-shared --enable-swscale
  WARNING: library configuration mismatch
  swscale     configuration: --extra-version='4:0.7.6ubuntu0.11.10.1'
--arch=arm --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm
--enable-libschroedinger --enable-libspeex --enable-libtheora
--enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx
--enable-runtime-cpudetect --extra-cflags='-marm -fPIC -DPIC'
--enable-vaapi --enable-libopenjpeg --enable-gpl --enable-postproc
--enable-swscale --enable-x11grab --enable-libdirac --enable-libmp3lame
--enable-librtmp --enable-libx264 --enable-libxvid --enable-libvo-aacenc
--enable-version3 --enable-libvo-amrwbenc --enable-version3
--enable-libdc1394 --shlibdir=/usr/lib/neon/vfp --extra-cflags='-mfpu=neon
-fPIC -DPIC' --enable-shared --disable-static --disable-ffmpeg
  postproc    configuration: --extra-version='4:0.7.6-0ubuntu0.11.10.1'
--arch=arm --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm
--enable-libschroedinger --enable-libspeex --enable-libtheora
--enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx
--enable-runtime-cpudetect --extra-cflags='-marm -fPIC -DPIC'
--enable-vaapi --enable-gpl --enable-postproc --enable-swscale
--enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/neon/vfp
--extra-cflags='-mfpu=neon -fPIC -DPIC' --enable-shared --disable-static
--disable-ffmpeg --disable-ffplay
  libavutil      52. 12.100 / 52. 12.100
  libavcodec     54. 81.100 / 54. 81.100
  libavformat    54. 49.102 / 54. 49.102
  libavdevice    54.  3.102 / 54.  3.102
  libavfilter     3. 29.100 /  3. 29.100
  libswscale      2.  1.103 /  2.  0.  0
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  0.  0
Please use -b:a or -b:v, -b is ambiguous
[video4linux2,v4l2 @ 0x1bb6d70] Estimating duration from bitrate, this may
be inaccurate
Input #0, video4linux2,v4l2, from '/dev/video3':
  Duration: N/A, start: 59.798126, bitrate: N/A
    Stream #0:0: Video: mjpeg, yuvj422p, 640x480, 0 kb/s, 5 tbr, 1000k tbn,
5 tbc
ffmpeg: relocation error: /usr/local/lib/libavfilter.so.3: symbol
sws_get_class, version LIBSWSCALE_2 not defined in file libswscale.so.2
with link time reference

Would be great to get your help.

More information about the ffmpeg-user mailing list