[FFmpeg-user] ffplay and mpeg1video files

Robert A. Schmied ras at acm.org
Thu Dec 27 19:57:21 CET 2012

Roger Pack wrote:
>>yes i have SDL installed -- it came with ffmpeg which
>>was part of a csw package. and yes 0.4.9 uses SDL for
>>the video window.
> So you are using the same version of sdl? what's the output from
> configure (though I suppose if it generates "ffplay" then it thinks it
> has SDL installed and working and is using it...)
aloha roger

are you really asking for all the output from configure?
if so please let me know and i'll regenerate it for you using
the sunpro c compiler -- a make distclean to start fresh removes
it (even if its been rotated with a filename suffix.
(e.g. $(RM) config.*) kinda brutal ...)

if you carefully re-read my initial post you will see that
some parts of the sunpro cc build did in fact work (an avi
and msmpeg4v2), just the mpeg1video files were not working.
(and subsequent posts (that still have not made it to the
archive yet) list the failing tests using the fate facility
with encouragement from carl).

as for the version of SDL:
   %    sdl-config --version
a bit old, but apparently still usable -- my just completed
gcc build worked just fine once i figured out that configure
mis-configured things by setting
   -mcpu=ultrasparc -mtune=ultrasparc

i ran into this assembler error
  /var/tmp//cckTNr4u.s: Assembler messages:
  /var/tmp//cckTNr4u.s:1946: Error: Illegal operands: There are only 32 single precision f registers; [0-31]
on three different files before hitting upon *the* configuration
    -mcpu=v9 -mno-vis and no setting for -mtune

i didn't see any way to encourage those values from configure
arguments, so i forced them in configure where it was setting
them incorrectly.

for what it is worth i'm on a sun4u sparc with ultrasparc-iii
   %    uname -a
   SunOS x 5.10 Generic_118833-33 sun4u sparc SUNW,Sun-Blade-1000

the only -mcpu= setup i was able to find that worked for the known
offending files:
was -mcpu=v9 and *no* -mtune value. this might very well be this
gccs' version issue ...
   gcc (GCC) 3.4.3 (csl-sol210-3_4-branch+sol_rpath)

but now i'm set -- the build worked fine and the non-working .mpg
files (mpeg1video) files 'play' just fine.

thanks to all the ffmpeg developers!



More information about the ffmpeg-user mailing list