[FFmpeg-user] ffplay and mpeg1video files

Robert A. Schmied ras at acm.org
Thu Dec 27 03:10:48 CET 2012

Carl Eugen Hoyos cehoyos at ag.or.at
writes to ffmpeg-user ml but not directly to me
> Robert A. Schmied <ras <at> acm.org> writes:
> > proceeded to downloaded and build 'angel' on solaris 10 sparc
> > with ancient sunpro c 5.8 (from sunpro 11).
> Without reading any further, I would have guessed that it 
> does not actually work. (I used to test sunpro myself but 
> stopped at some point because there were too many problems.)
> > with only some minor tweaks
> > to configure and config.mak it built ok;
> ... one could even argue that if you changed your local 
> copy of FFmpeg, you cannot get support;-(
> (But reporting compilation problems is of course *very* 
> welcome!)
> [...]
> > but ffplay will not display it. it (ffplay) reports stats on 
> > tty but does not open a video window.
> But to stop guessing, I suggest you upload the sample so 
> we can test on a known working platform.
> To make absolutely sure, you can run:
> $ make SAMPLES=fate fate-rsync
> $ make SAMPLES=fate fate
> This will show you all codecs for which compilation failed...
> Carl Eugen

aloha carl and ffmpeg gurus

i'm willing to help any way i can.

i also suspect there are problems with the build using sunpro c.

as far as reporting compilation problems -- the ffmpeg changes
were specifically related to my atypical environment, platform
and for sunpro c 5.8. if you really think they are useful
i will rollup a set of diffs.

the files and very brief description of change:
  ./libavutil/mem.h -- #elif conditional defined(__SUNPRO_C) && __SUNPRO_C <= 0x580
  ./libavformat/nsvdec.c -- #if conditional #define __FUNCTION__ __func__
  ./configure -- hashbang line change; -G not -shared if enabled suncc

as far as "uploading" the failing sample video file: there
is no need as the test results below indicate.

i tried the (g)make commands, got these results:
%    /usr/local/bin/gmake  SAMPLES=fate fate-rsync |& tee gmake-fate.log
rsync -vaLW --timeout=60 --contimeout=60 rsync://fate-suite.ffmpeg.org/fate-suite/ fate
rsync: --contimeout=60: unknown option
rsync error: syntax or usage error (code 1) at main.c(1084)
gmake: *** [fate-rsync] Error 1

my rsync  version 2.6.3  protocol version 28

not knowing for sure what the rsync stuff is all about i did
%    /usr/local/bin/gmake SAMPLES=fate fate | & tee -a gmake-fate.log
crashed when ./tests/fate-run.sh was run
hashbang line:  #!/usr/bin/bash for this solaris -- the problem was

    export LC_ALL=C

and finally got results: these are the failing tests:

right about here i ran out of space on the build partition
-- is there a way to conserve or reclaim disk space automatically?


my plan is to start over with fresh, unchanged ffmpeg-1.0.1 and
configure for gcc 3.4.3 ... but i'm thinking it (gcc) is way too old.
(GCC) 3.4.3 (csl-sol210-3_4-branch+sol_rpath).

are there any things i need to be especially aware of using gcc?
it is configured to use gas (GNU assembler version 2.15) and suns ld
(ld: Software Generation Utilities - Solaris Link Editors: 5.10-1.482)
*not* gld.


merry christmas


More information about the ffmpeg-user mailing list