[FFmpeg-user] Compiling 0.10.2 under FreeBSD 9

Tom Evans tevans.uk at googlemail.com
Fri May 4 11:29:14 CEST 2012

On Fri, Apr 27, 2012 at 11:36 PM, Forrest Aldrich <forrie at gmail.com> wrote:
> The ports collection in FreeBSD has an outdated version of FFMPEG, and the
> port appears to have been abandoned.   We require the current version.
> I have all of the dependencies installed, however the basic ./configure
> process is not locating the dependencies correctly.  The first error is
> libfaac, which is clearly installed under /usr/local/lib.   I tried adding
> --extra-ldflags, but that's not going to help here.   I also made sure
> ldconfig was re-run for /usr/local/lib.
> I noticed the FreeBSD ports has a couple of minor patches, but I don't
> think they're really going to affect the current version.
> In any case, can someone lend a hand at fixing this problem with configure.
>  I hope that's the only problem I run into :-)
> Thanks,
> Forrest

I run FreeBSD 9.0. I install all dependencies (libraries) from ports
generally. The easiest way to do this is to go to the ffmpeg port,
configure it with the options you want, and install all dependent
libraries. (cd /usr/ports/multimedia/ffmpeg-devel && make config &&
make all-depends-list).

A couple of additional dependencies that may not come up in that list
- lang/gcc46, and the latest devel/binutils.

Once you have the dependencies installed, this is my build script for
building ffmpeg from git:

    cd ffmpeg
    git pull
    gmake distclean
    ./configure --as=/usr/local/bin/as --cc=/usr/local/bin/gcc46 \
        --extra-libs=-L/usr/local/lib --extra-cflags="-I/usr/local/include" \
        --prefix=/usr/local --mandir=/usr/local/man --disable-protocol=udp \
        --enable-postproc --enable-nonfree --enable-gpl --enable-version3 \
        --enable-libtheora --enable-libvorbis --enable-ffmpeg
--enable-ffplay --enable-ffprobe \
        && gmake -j 2

Hope that helps



More information about the ffmpeg-user mailing list