[FFmpeg-user] Compiling FFMPEG on the Mac, issue with configure and vorbis libs...

Jim Worrall coniophora at gmail.com
Sat May 12 01:55:34 CEST 2012

On May 9, 2012, at 4:54 PM, Forrest Aldrich wrote:

> I'm nearly done getting FFMPEG ready to compile - however, it is not finding the Vorbis libs, which are clearly installed.   I have tried setting CFLAGS and LDFLAGS to include /usr/local/lib and /usr/local/include which has had no effect.
> I tried commenting out the require line in the configure script, to see if that might just work and it did not.
> The C compiler is set to "clang".
> What is wrong?

I'm not sure if this is your problem.  I install on a Mac running 10.7.3.  I found out that libvorbis by default will configure itself for i386 architecture, so it won't match with ogg, which is set for x86_64.  I added --build=x86_64 to the libvorbis configure options, it worked.  

So my libvorbis install is:

./configure --prefix=${TARGET} --build=x86_64 --with-ogg-libraries=${TARGET}/lib --with-ogg-includes=/Volumes/Ramdisk/sw/include/ --enable-static --disable-shared --disable-oggtest && make -j 4 && make install;

It's a little strange because I install first on a Ramdisk.

More information about the ffmpeg-user mailing list