[FFmpeg-user] Strict Experimental / 3GP not working with LGPL Compilation

Tim Bradstock tim.bradstock at googlemail.com
Wed May 30 20:13:54 CEST 2012

Dear All,

I've historically used a GPL compiled version of FFmpeg to convert to the
3GP format and it worked perfectly with the following command line:

ffmpeg.exe -i sample1.flv -vcodec mpeg4 -acodec aac -strict experimental
-ac 1 123.3gp

However, in the last few weeks I've moved to a LGPL compilation for
licensing reasons. The LGPL builds were produced by Zeraneo based on

However, now I cannot get the above command line to work and cannot convert
to the 3GP format.

I am passing '-strict experimental' and the FFmpeg DLL returns a code which
suggests it has successfully accepted the parameter (it’s in opt_default
function). But later, in the code it fails with the same error – 'code is

I've also tried using the following command line but this also fails:

ffmpeg.exe -i sample1.flv -vcodec mpeg4 -acodec libvo-aacenc -ac 1 123.3gp

Can anyone help? Thanks.


More information about the ffmpeg-user mailing list