[FFmpeg-user] Concat error - No such filter '[0,0]'

jon h jon77h at gmail.com
Mon Feb 4 04:33:16 CET 2013

Hope this attaches to the right thread.
Tried to reply from Nabble, but it said
my message didn't go through to the mailing list.

In Mike Kavanagh's code:
   -filter_complex "concat=n=3:v=1:a=0 [a] [v]"
a=0 should be a=1
It's the number of output streams, not a stream index.

See the explanation here:
under the heading "Concatenation of files with different codecs".

Btw, the method given for concatenation of files with different codecs
is useful somtimes when the codecs are the same.
I was sent a ProRes file in 2 sections, with same codecs,
and tried to join them by transcoding first then using
mkvmerge or mp4box cat, which both gave imperfect results.
When i used -filter_complex concat, the result was great.

About quoting on the Windows command line,
this style worked for me (on Vista) --

:: double quotes around the filter string
-filter_complex "[0:0] [0:1] [1:0] [1:1] concat=n=2:v=1:a=1 [v] [a]"

:: then with -map, no quotes
-map [v] -map [a]

:: then elsewhere, no brackets
-c:v libx264 -preset:v slow ... etc
-c:a libvorbis ... etc

-- j77h

More information about the ffmpeg-user mailing list