[FFmpeg-user] pts/dts error using reset_timestamps while splitting a DVD

Stefano Sabatini stefasab at gmail.com
Wed Feb 6 00:50:23 CET 2013

On date Tuesday 2013-02-05 10:31:37 +0000, Owen Jones wrote:
> On 23 Jan 2013, at 10:08, Carl Eugen Hoyos <cehoyos at ag.or.at> wrote:
> > If you use the segmenting on the original vob file, do 
> > you see the same error?
> I've rebuilt ffmpeg again with I think the latest git version. I'm
> still getting the error running against the raw vob file copied from
> DVD.
> I've also tried using -ss instead and this works fine. I could use
> this as an alternative (with -t) but it will be very clumsy since I
> need to make a lot of splits. I'd still really appreciate a solution
> to the segmenting problem if there is one...

I confirm this is a bug.

Please try the attached patch, and report if it works for you.
FFmpeg = Forgiving and Fierce Minimalistic Practical Ecumenical Guru
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0006-lavf-segment-fix-DTS-inconsistencies-with-reset_time.patch
Type: text/x-diff
Size: 2900 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20130206/847cc18d/attachment.bin>

More information about the ffmpeg-user mailing list