[FFmpeg-user] newbie installation bug

mark edwards edwardsmarkf at gmail.com
Mon Jan 14 01:36:11 CET 2013

hello carl - thank you for writing me back.

i should have mentioned right away that i ran totally through the procedure
originally just doing configure/make/make install.

later i went back in and tried to add the 'opus' option when i realized
that opus was not installed by default.

but whats throwing me is that it fails on 'make test', not the make itself.
 the configure and the make seem to finish with no problems, which is
usually the most difficult part.

the libdir command you noted was created out of desperation.  i probably
run through a configure/make procedure every other year and avoid doing it
at all cost  (thank you "yum').

 gcc  --version  ;
gcc (GCC) 4.4.6 20120305 (Red Hat 4.4.6-4)
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

On Sun, Jan 13, 2013 at 4:43 PM, Carl Eugen Hoyos <cehoyos at ag.or.at> wrote:

> mark edwards <edwardsmarkf <at> gmail.com> writes:
> > git clone git://source.ffmpeg.org/ffmpeg.git ffmpeg  ;
> >
> > ./configure  --libdir=/usr/local/lib,/usr/local/include  --enable-libopus
> Could you test the following?
> $ ./configure && make
> It should make no difference, but your libdir command
> looks a bit strange to me...
> If it works, it produces a working ffmpeg executable,
> make install should not compile anything (and therefore
> cannot fail with a compiler error).
> If it fails, please add the output of:
> $ gcc --version
> Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

More information about the ffmpeg-user mailing list