[FFmpeg-user] RTSP Latency Question

Tom Hendrick sdtom182 at yahoo.com
Mon Jan 14 19:20:36 CET 2013


I am working with an rtsp stream from an Axis IP camera and am 
seeing some latency issues.  There was a separate thread that mentioned a 
patch from Marton Balint and I posted a response but it wasn't accepted 
for some reason. 

Basically, when I use the command  ffplay -i 
rtsp:// i see about 1 second of latency when
 waiving my hand in front of the camera.  I tried several settings 
including probesize and analyze duration and I could not get the latency
 down any more. 

When I try this with mplayer using the following command: mplayer rtsp://
  it plays the stream right away and there is practically no latency at 

What I am most interested in doing is re-encoding the rtsp stream to an h.264 stream 
and writing to a piped file. When I re-encode with ffmpeg and open the piped file with ffplay I still see the latency of a second or more. 

Is the bug/fix that Marton Balint worked on likely to help my 
situation?  Is the rtsp bug/fix just for ffplay, or will it affect ffmpeg? 

Thank you.

More information about the ffmpeg-user mailing list