[FFmpeg-user] problem with ffmpeg on "ts" file

attio1_tiscali attio1 at tiscali.it
Mon Jan 21 10:42:08 CET 2013

Hi all,
I have a tv decoder what creates a transport stream when it records a 
I proved to encode an “.avi” or a “prova2.ts” file (prova2.ts is the 
file create by decoder) to transport stream (prova.ts is the output 
file), but I didn't see anything on screen (black screen with decoder, 
but ok with computer).
I proved to do the same operation with "AVS Video Converter" and I 
hadn't problem with the decoder (by progress or interleaved frames).
The problem appear when I push play button (in the static way I see a 
on my television set, the first frame of .ts).
I compared the result of MediaInfo about the output file (prova.ts) with 
the original file (prova2.ts), I have not seen important differences 
between the two files.
A this point I think that the problem is about libav codec.
The same problem appeared if I used “avidemux_2.6.1” on my windows xp, 
but I had no
problem with "AVS Video Converter" on the same windows xp.
I saw the file done with cli “ffprobe -show_frames prova.ts > ffprobe_appo”,
I noted a difference between prova2.ts and my encode file prova.ts:
a) with “ffmpeg” the video file begins with audio frame on prova2.ts and 
video frame on prova.ts.
b) with “AVS Video Converter” the video file begins with audio frame on 
prova2.ts and prova.ts.
I tried with ffmpeg version number 11 (the version that I had on my 
puppy linux) and I had the problem. So I tried with the last version of 
ffmpeg and I also had the same problem.
This is the ffmpeg configuration:

ffmpeg version 1.1 Copyright (c) 2000-2013 the FFmpeg developers
built on Jan 19 2013 12:30:46 with gcc 4.7.1 (GCC)
configuration: --prefix=/usr --cpu=i686 --enable-libmp3lame 
--enable-libx264 --enable-libfaac --enable-pthreads --enable-small 
--enable-postproc --enable-libvorbis --enable-gpl --enable-shared 
--enable-nonfree --enable-libopencore-amrnb --enable-libopencore-amrwb 
--disable-debug --enable-bzlib --enable-zlib --enable-libspeex 
--enable-version3 --enable-runtime-cpudetect --enable-x11grab 
--enable-libdc1394 --enable-libschroedinger --enable-libtheora 
--enable-libxvid --enable-swscale --enable-libvpx
libavutil 52. 13.100 / 52. 13.100
libavcodec 54. 86.100 / 54. 86.100
libavformat 54. 59.106 / 54. 59.106
libavdevice 54. 3.102 / 54. 3.102
libavfilter 3. 32.100 / 3. 32.100
libswscale 2. 1.103 / 2. 1.103
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 2.100 / 52. 2.100

The cli command on ffmpeg is:
“ffmpeg -i prova2.ts -vcodec mpeg2video -s 720x576 -aspect 4:3 -b:v 
6200k -minrate 5000k -maxrate 10000k -bufsize 1835k -r 25 -bf 2 -flags2 
sgop -acodec mp2 -ac 2 -ar 48000 -ab 224k prova.ts”.
If I changed the extension of output file from “ts” to “mpg” and I put 
it on dvd, I hadn't problem on my video recorder.

Does anyone know any news about my problem?
I hope some answers, thanks for the moment.
Best regards,

More information about the ffmpeg-user mailing list