[FFmpeg-user] More issues with the -t option (segment extraction)

Jeanne Rich jrich at laika.com
Mon Sep 23 06:49:05 CEST 2013

I tried the frames:v 10 with the -ss option and my audio was too short.

I've tried it with the audio, but I can't seem to get the correct sample count, I've tried it with the atrim and that didn't work either.  Finally I tried the trim option and that didn't do anything.

----- Original Message -----
> U can use -frames option to define the exact number of frames to extract.
> It is possible to define number of frames per stream id (video/audio)  -
> "-frames:0 900 -frames:1 2586"
> On Mon, Sep 23, 2013 at 7:31 AM, Jeanne Rich <jrich at laika.com> wrote:
> > I am trying to extract a segment out of an mjpeg quicktime movie using the
> > -ss and -t options. However, when I do this I get more frames than I
> > wanted. In this case I am trying to extract 10 frames, the audio is short
> > with with a start_pts that is not 0, and the video is 1 frame too long. I
> > tried using the frames:v option, but when I did that the audio was too
> > short. Finally I tried the trim filter but that did nothing. I am using the
> > git-head from Friday.

More information about the ffmpeg-user mailing list