[FFmpeg-user] Issue capturing stream

Moritz Barsnick barsnick at gmx.net
Fri Apr 10 19:47:35 CEST 2015

On Fri, Apr 10, 2015 at 19:27:32 +0200, Stein Rune Risa wrote:
> I did try the following:
> ffmpeg -i http://nordond37a-f.akamaihd.net/i/no/open/e7/7ce57559d11e341d6048d128c40f8697701cb56/29ae0629-1b05-4b19b5a9-dd601ede6a0a_,141,316,563,1266,2250,.mp4.csmil/index_4_v.m3u8 -map 0:v -map 0:a -c copy test.mkv
> I am still getting an error, but it is working fine if I use "-c:v" instead
> - which I though only copied video?
> I am unsure how the command line should look - maybe you could advise?

You should usually post the complete, uncut output. It extremely helps
in understanding the issue without the need to reproduce.

I can't access that URL, it seems to be of a program NRK does not
provide internationally (the "/no/" component in the URL). I tried a
different URL:


Indeed, there's a further issue than the one I first tried to solve.
Indeed "-c copy" indeed gives some issues:

[matroska @ 0xac494c0] Codec for stream 0 does not use global headers but container format requires global headers
[matroska @ 0xac494c0] Codec for stream 1 does not use global headers but container format requires global headers
[matroska @ 0xac494c0] Error parsing AAC extradata, unable to determine samplerate.

ffmpeg refuses to mux this AAC into MKV. I am convinced it used to
work. D'uh. I believe I always got an error with the hint to use
"-bsf:a aac_adtstoasc", and that hint always worked, but now no longer.

The change was introduced in commit
51da7d02748cc54b7d009115e76efa940b99a8ef in January 2015. I don't know
what to do now than to re-encode audio. (Which you did by changing "-c
copy" to "-c:v copy").

Does anybody else know what to do about this AAC issue without

BTW, I remux NRK streams to MPEG-TS for my PVR, and they work fine
there. (The original streams are MPEG-TS HLS anyway.)


More information about the ffmpeg-user mailing list