[FFmpeg-user] Building FFMPEG and enabling x265

Alexander Martin Dethof alexander.m.dethof at campus.tu-berlin.de
Tue Apr 14 15:41:49 CEST 2015

Hello everybody,

I am trying to build the current version of ffmpeg. For this purpose I use the
description of the compilation guide:
http://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu. Further more I want to
enable libx265 in my ffmpeg configuration. So I installed x265 before  
by this description:

sudo apt-get install mercurial cmake cmake-curses-gui build-essential yasm
hg clone https://bitbucket.org/multicoreware/x265
cd x265/build/linux

(The x265 folder lays in the ffmpeg_sources folder)

My problem is now to integrate it into my ffmpeg configuration:

PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig"
./configure \
  --prefix="$HOME/ffmpeg_build" \
  --extra-cflags="-I$HOME/ffmpeg_build/include" \
  --extra-ldflags="-L$HOME/ffmpeg_build/lib" \
  --bindir="$HOME/bin" \
  --enable-gpl \
  --enable-libass \
  --enable-libfdk-aac \
  --enable-libfreetype \
  --enable-libmp3lame \
  --enable-libopus \
  --enable-libtheora \
  --enable-libvorbis \
  --enable-libvpx \
  --enable-libx264 \
  --enable-libx265 \

Returns me always:

ERROR: x265 not found using pkg-config

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user at ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.

I also tried to modify the PKG_CONFIG_PATH var to  
"$HOME/ffmpeg_sources/x265/build/linux:$HOME/ffmpeg_build/lib/pkgconfig", but  
I still get the same output.

How can I solve the problem? For your reply I want to thank you in forward!


More information about the ffmpeg-user mailing list