[FFmpeg-user] Fwd: Trying to compile ffmpeg-ios

Moritz Barsnick barsnick at gmx.net
Sat May 9 21:40:40 CEST 2015

On Fri, May 08, 2015 at 23:41:11 -0700, Travis Bader wrote:

> I am having issues compiling ffmpeg-ios that I obtained from
> https://github.com/chrisballinger/FFmpeg-iOS

That's not ffmpeg, that's someone's script.

> Downloading ffmpeg-2.2.tar.bz2

Why does it use a not-so-recent version of ffmpeg? Git is recommended
here, and 2.6.2 is latest release.

> ERROR: librtmp not found

You need to install librtmp and its development libraries and headers
for the option --enable-librtmp to work. Does the script not do that
for you? Or instruct you to do something?

There's also a "build-librtmp.sh" on that github page, BTW...

You also quoted this as part of the output in your email:
> Include the log file "config.log" produced by configure as this will help
> solving the problem.

But you didn't do it. Why not? Anyway, the "ERROR" you quoted above
happens to be enough to understand the issue.

> I have tried Xcode5.1.1, 6.1.1 and 6.1 and get the same result for each.

Those are the build environments, but have nothing to do with the
missing dependency.


P.S.: Unfortunately, I bothered to look at the script's github page.
Did you read and follow the instruction? Not that I care:
  Just drag the /dependencies/include and /dependencies/lib folders into
  your Xcode project and add them to your build target. If you want to,
  you can modify the build-ffmpeg.sh script to suit your needs and

More information about the ffmpeg-user mailing list