[FFmpeg-user] ffmpeg CL translation from Linux to Windows

MrNice wxcvbn2006 at iol.ie
Fri Nov 13 19:37:54 CET 2015

On 13/11/15 15:35, Claudiu Rad wrote:
> On 11/8/2015 8:25 PM, MrNice wrote:
>> Hi,
>> I need to compare ffmpeg behaviour between Linux and Windows.
>> I installed Virtualbox on my Fedora host and Win 8.1 as guest.
>> Now I need to translate the Linux CL
>> ./ffmpeg -debug 1 -xerror -f pulse -ar 44100 -ac 2 -channel_layout
>> stereo -thread_queue_size 512 -i
>> alsa_input.pci-0000_00_14.2.analog-stereo -f v4l2 -ts mono2abs -channel
>> 1 -video_size 720x576 -pix_fmt yuyv422 -thread_queue_size 512 -i
>> /dev/video0 -c:v libx264 -vf setfield=tff -preset slow -qp 0 -x264opts
>> tff=1 -aspect 4:3 -pix_fmt yuv422p -c:a pcm_s16le -channel_layout stereo
>> /Store3/Test/t_`date +%Y%m%d_%H%M`.mkv -aspect 4:3 -f sdl "Dazzle
>> output".
> so you are trying to compare the capture from a USB device but want to
> run windows inside a VM?
> i surely wouldn't recommend that, there are many many things that may go
> wrong.
> it's way better to install windows side-by-side with linux on a
> different drive/partition, make all updates, install all drivers and let
> him do his job without linux/VM layers.
> and please.. when investigating and posting things, resume to simplest
> command line possible that reproduces the issue.

Thanks Claudiu for you answer and time.

In fact my comparison is related to the bug I found see here
(you posted once on it) and the bug I placed see here
For few months, I tried to get the "perfect" command line and I think I
have it. Moreover, I have 2 of them, one with FFV1 the other X264.
However when I tried in the real config I found this @&*%@@#£$% (ban) bug.

I am stuck with this bug and I can't go further in my personal project.
I try to add info, hoping this will help experts in this forum or
developers in the trac.ffmpeg.

To say the truth I tried to find another tool to do the capture but so
far unsuccessfully (I want audio and video "lossless" capture,
interlaced). What is very frustrating to me (this is a personal/family
project) is to post and have to wait long time with hope that someone
will post an answer, even without a solution, just to say "I have read
it but ...". (so far 8 weeks on trac.ffmpeg). Maybe I'll never have an
answer :-( In my case the best should be to get the answer "We will try
to debug in 6 months/1 year/3 years/never". At least I'd find out about it.
Please don't take it for you and all here, I know you are helping a lot
along your free time, you all are doing a very valuable work and I
really appreciate it.
These few above sentences are just to tell you how I am happy to get
your answer and in the same time new hope :-)
So thanks again.

Back to the point; Windows is only to check if the bug occurs as well. I
don't want as much as possible to use Win. Last time I used it was
NT/2000... and I don't have an available computer for it and don't want
to damage my running config. Anyway, first is to know if it's working,
so I need to test.

I don't know what is the culprit and I am wondering if I could change my
capture hardware. Do you know?
I am wondering if I could have a look in the source code, but I even
don't know where to look...
So, I am ready to spend some time but I need support and directives.

Aside, if you know what tool I could use as a replacement (audio and
video "lossless" capture, interlaced), please let me know, first Linux
then Win if there is no choice.

Many thanks to have read this long post.
Hope is here again...

More information about the ffmpeg-user mailing list