[FFmpeg-user] convert HLS stream to UDP

a@fumatic.org a at fumatic.org
Fri Nov 13 19:59:15 CET 2015

your 'local' test is not a valid test,
your not using the same container or protocol. 

split your steps for testing maybe.

try writing the file on the server using an mpegts container
ffmpeg -i http://example.com/master.m3u8 -c copy master.ts

and then after you have written the file.

ffmpeg -i master.ts -f mpegts udp://

and see if it plays

that should make it clearer as to where the issue lies.

----- Reply message -----
From: "Sorin Esanu" <sorin at evox.ro>
To: <ffmpeg-user at ffmpeg.org>
Subject: [FFmpeg-user] convert HLS stream to UDP
Date: Thu, Nov 12, 2015 2:19 PM


I am trying to convert (without transcoding) an HLS stream to UDP and 
send it to my computer. For that I use this command, unnder Ubuntu 14.04:

./ffmpeg -i 
-map 0:1 -map 0:2 -c:v:0 copy -c:a:0 copy -f mpegts udp://

I am then using VLC on Windows to view that stream (udp://:1234).
It does not work, as the video it's all some random colored squares and 
audio is just some random noise and cracking.

Using same command to save the file local:

./ffmpeg  -i 
-map 0:1 -map 0:2 -c:v:0 copy -c:a:0 copy test.avi

produces a perfectly readable file that I can view with VLC.

I've tried various options here (with and without transcoding), 
multicast... nothing. I get the same unusable video and audio.

Could you tell me what am I missing here? There is no packet loss 
between my Windows computer (the one with VLC) and the Ubuntu server.
I've also tried other computers with same result.

Thank you and sorry if this is a trivial question! I do not have 
experience playing with video streams, or at least not more than viewing 
them in VLC.

ffmpeg-user mailing list
ffmpeg-user at ffmpeg.org

More information about the ffmpeg-user mailing list