[FFmpeg-user] Understanding stats infos

MrNice wxcvbn2006 at iol.ie
Sun Nov 29 17:00:22 CET 2015

On 29/11/15 10:59, MrNice wrote:
> Hi,
> When I record from v4l2 in debug mode, I get no error message, only
> green lines.
> ./ffmpeg -debug 1 -f pulse -ar 44100 -ac 2 -channel_layout stereo
> -thread_queue_size 1024 -i alsa_input.pci-0000_00_14.2.analog-stereo -f
> v4l2 -use_wallclock_as_timestamps 1 -itsoffset 1.69 -channel 1
> -video_size 720x576 -pix_fmt yuyv422 -thread_queue_size 1024 -i
> /dev/video0 -c:a pcm_s16le -channel_layout stereo -c:v ffv1 -level 3 -g
> 1 -aspect 4:3 -pix_fmt yuv422p -top 0 -vsync passthrough
> /Store3/Test/t_`date +%Y%m%d_%H%M`.mkv
> Then when I run the following command on the file I get a lot of same
> errors in red.
> Are these errors recorded in the file or are they generated when reading?

More info
When I record with the above command, I don't get any warning/error
message at the time of recording.
When I run the following command on the generated file
./ffmpeg -i /Store3/Test/filename.mkv -f null /dev/null
I get a lot of red messages
Application provided invalid, non monotonically increasing dts to muxer
in stream 0:

If I remove the last output option: -vsync passthrough
When I record I get a lot of warning messages
Past duration 0.646019 too large
Cliping frame in rate conversion by 0.523094
When I run the following command on this file
./ffmpeg -i /Store3/Test/filename.mkv -f null /dev/null
I get NO error message at all

What does the mean?

More information about the ffmpeg-user mailing list