[FFmpeg-user] Errors running 'make check' when openh264 enabled

C E Macfarlane c.e.macfarlane at macfh.co.uk
Wed Oct 21 01:31:40 CEST 2015

Hi all,

Running Ubuntu 14.  Successfully compiled, tested, and installed openh264
into /usr/local/lib.

FFMPEG 2.8.1 configured as follows:
	./configure --enable-gpl --enable-nonfree --enable-libopenh264 --disable-po
dpages --disable-txtpages

Both './configure' and 'make' complete, but 'make check' errors with:

TEST    api-flac
Test api-flac failed. Look at tests/data/fate/api-flac.err for details.
make: *** [fate-api-flac] Error 127
/home/build/ffmpeg-2.8.1# cat tests/data/fate/api-flac.err
/home/build/ffmpeg-2.8.1/tests/api/api-flac-test: error while loading shared
libraries: libopenh264.so.0: cannot open shared object file: No such file or

Have tried helping the existing library be found by running 'make clean',
adding ...
... into the configure command, and rebuilding, but 'make check' still fails
with the same error.

What should I do?

Thanks and regards,
C E Macfarlane


More information about the ffmpeg-user mailing list