[FFmpeg-user] Need help with ffmpeg library installation on RHEL5

Moritz Barsnick barsnick at gmx.net
Tue Feb 2 14:44:49 CET 2016

[Please don't top-post.]

On Tue, Feb 02, 2016 at 13:24:23 +0000, Kachhawal, Vijay P wrote:
> I tried installing locally after downloaded rpm package from the site
> which returned me with the error list I shared in the email. Then I
> tried installing the dependent library one by one but I reached to a
> stage where libraries were interdependent which I could not resolve.
> Just to add, I am not a regular user of Linux machines so do not have
> much idea how the things works. Even I tried "yum install ffmpeg"
> option but that also resulted in errors.

Packages from repositories can always have dozens of dependencies, and
further subdependecies. Rather than asking us, you need to ask the
packager, or even better, ask the repository. There are tools for doing
that, i.e. resolving dependencies: "Package managers".

I assume that https://www.ffmpeg.org/download.html directed you to
http://rpmfusion.org/ . Right?

On that page, follow the link:
"Enable RPM Fusion on your system"

>From there, see
"Command Line Setup using rpm"
-> "RHEL 5 or compatible like CentOS"

When you are done activating the repo, you get ffmpeg by doing:
$ yum install ffmpeg
(I think RHEL5 is yum based.)

That will download and install *all* dependencies. There will be more
than just ffmpeg-libs, as rpmfusion's ffmpeg links against a lot of
libraries, which are all packaged separately (and rightly so).

If you "just want to test", I think there are static builds available
here (non-RPM):
There you also get "recent" builds from git master.

> Please help me with some simple steps to install this library.

It's simple, and the instructions are all on that site you got liked
to. ;-)


More information about the ffmpeg-user mailing list