[FFmpeg-user] VFR video re-encoding

Nicholas Robbins nickrobbins at yahoo.com
Tue Feb 9 03:10:07 CET 2016

> On Monday, February 8, 2016 1:42 AM, ValdikSS <iam at valdikss.org.ru> wrote:

> > I'm trying to make a webm from it, saving VFR. To visually understand if the 
> video is playing fine, look how Stripperella sign fades in.
> This command gives 23.98 CFR as expected, dropping frames as it reaches opening. 
> Opening stutters, as expected:
> $ ffmpeg -i rkszxnz.mkv -threads 3 -speed 5 test.webm

> Adding -vsync 0:
> $ ffmpeg -ss 00:00:45 -i rkszxnz.mkv -t 00:00:30 -b:v 0 -crf 40 -threads 3 
> -speed 4 -vsync 0 test2.webm

This worked fine with me if I removed the "-ss" and "-t" options. It played fine in VLC at lease. I reported no dropped/dupped frames in the encode. It reported that it was 23.9 fps, but actually contained all 3166 frames of the original.

When I added the -ss and -t options I got segfaults.  The command that worked for me was:

$ ffmpeg -i rkszxnz.mkv -threads 3 -speed 5  -vsync 0 test.webm


More information about the ffmpeg-user mailing list