[FFmpeg-user] Unable to initialize SDL, over X11 for only root

Jeff secjeff at gmail.com
Sun Apr 1 23:28:28 EEST 2018

´╗┐Moritz  / all,

I thought we had all of our X11 issues solved with v3.4.0 of FFMpeg and SDL
v2.0.7 (both built with standard configure/make/make install), but have
since come across an unusual error.   When launching *ffplay* as any normal
user (X11 or direct terminal/desktop), I am able to play videos without a

However when running *ffplay* as the root user over X11 on the same files,
I am getting met with the '*Unable to initialize SDL*' error.

If I run that same file as the root user directly its root desktop (vice
X11), it launches just fine.  So it's only root over X11 (and possibly in
VM vs. a pure hardware platform, but will need to confirm that).

I came across this (
thread/post form Moritz indicating there may be an issue using ffplay as

In this particular case, there is a program daemon which is run as root
that calls ffplay.  This is why the call is being made by the root user.
It seems something is different in the case of root over X11 vs. a direct
terminal call from the root user's desktop, but I don't have the foggiest

Any thoughts would be greatly appreciated.



More information about the ffmpeg-user mailing list