[FFmpeg-user] Reencoding video from image sequence doesn't work (sometimes)

DopeLabs dopelabs at dubstep.fm
Thu Jan 25 15:07:28 EET 2018

have you tried different players such as ffplay, mpv, IINA, mplayer?

have you tried a different encapsulation such as .mp4 or .flv or .mov?

looking at your console output..


maybe try and have those more often?

or maybe try and pad the beginning with a few black frames?

if it works 99% of the time does that mean videos seem to faile 1% of the time at random? or can you try again and it will work properly?

> On Jan 23, 2018, at 9:54 49AM, serialhex at gmail.com wrote:
> DopeLabs wrote
>> once you have your image sequence, encoding them into a movie should be
>> pretty straight forward.
> And that's the rub.  It *is* straightforward, and what I'm trying to do
> works on 99% of my videos, but for some reason, there are a handful of
> videos where the picture DOES NOT START when the rest of the video does. 
> Audio starts, and subtitles might, but the picture DOES NOT.
> Fastforwarding the video to some arbitrary point and then rewinding to NEAR
> the beginning works, but if you rewind ALL THE WAY to the beginning whatever
> WAS on the screen just stays there and never updates.
> One of the things I just realized is playing the video all the way through
> the picture eventually comes in, and I get messages like this:
> ...
>  Stream #1:1 -> #0:1 (aac (native) -> vorbis (libvorbis))
>  Stream #1:2 -> #0:2 (ass (ssa) -> ass (ssa))
>  Stream #1:3 -> #0:3 (copy)
> Press [q] to stop, [?] for help
> [image2 @ 00000000002da3e0] Thread message queue blocking; consider raising
> the thread_queue_size option (current value: 8)
> [matroska @ 00000000032254a0] Starting new cluster due to timestamp= 
> 93.4kbits/s speed=11.2x
> [matroska @ 00000000032254a0] Starting new cluster due to timestamp=
> 963.1kbits/s speed=2.19x
> frame=26853 fps= 40 q=-1.0 Lsize=  179749kB time=00:23:20.00
> bitrate=1051.8kbits/s speed=2.06x
> video:162698kB audio:16217kB subtitle:21kB other streams:0kB global
> headers:6kB muxing overhead: 0.454852%
> [libx264 @ 00000000031c98e0] frame I:638   Avg QP:18.35  size: 41747
> ...
> What's up with the "Starting new cluster due to timestamp= ..." thing?  It
> doesn't record the actual timestamp in the output later, but I recall it did
> that saying it was at about 2 minutes, and at about 2 minutes in the picture
> appears (which doesn't seem to help on my Raspberry Pi at all).
> Also, this problem only seems to happen on *some* players.  Since VLC is the
> only thing that really plays MKV files, it's the only thing I can use to
> test, but while VLC doesn't play these files from the beginning, Chrome
> seems to work just fine.  Again, my this doesn't help on my Pi.
> Recently I've tried to not just copy everything except the picture, but
> reencode everything.  This didn't work either.
> Thanks for any further help.
> p.s. 
> Carl Eugen wrote
>> I assume you tested that this is better than FFmpeg's (old)
>> super2xsai filter. Is it also better than FFmpeg's hqx filter?
>> (You agree that faster alone doesn't really help if you have
>> to reencode twice, no?)
> I checked this out after you recommended it, and it doesn't do nearly as
> good a job as my super-long 2+ hour encoding process makes my crappy
> TV-quality videos into damn-near HD-quality videos.  Thanks for the
> suggestion though. 
> --
> Sent from: http://www.ffmpeg-archive.org/
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
> To unsubscribe, visit link above, or email
> ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".

More information about the ffmpeg-user mailing list