[FFmpeg-user] vaapi: Impossible to convert between the formats

Mark Thompson sw at jkqxz.net
Sun Jun 17 23:44:10 EEST 2018

On 17/06/18 21:30, Carl Eugen Hoyos wrote:
> 2018-06-17 22:00 GMT+02:00, Mark Thompson <sw at jkqxz.net>:
>> Intel devices do not support MPEG-4 part 2 at all.  If you are using
>> the Mesa driver on an AMD device, some MPEG-4 part 2 streams
>> may be supported if you set the environment variable
>> VAAPI_MPEG4_ENABLED to 1, but it's not enabled by default
>> because the implementation is incomplete due to API constraints.
> I know this mail isn't helpful but reading above and remembering how
> nice vdpau worked (already) many years ago and remembering how
> people said at the time that vaapi is much superior over vdpau I still
> wonder if we (FFmpeg) shouldn't have fought vaapi much stronger...

I doubt it would be particularly hard to make it work.  Since Intel didn't implement MPEG-4 part 2 on their supported devices they just cobbled together some set of stream/frame properties which looked sufficient for decoding and  made that the API.  When AMD / Mesa tried to implement it they made some of it work but found that the API was incomplete, and then they gave up.  If you (or anyone else, including AMD) wants it to work then it would be straightforward (if somewhat tedious) to add the necessary properties to VAAPI / libva to get to the point that it matches the working VDPAU behaviour.

- Mark

More information about the ffmpeg-user mailing list