[FFmpeg-user] Unable to stream SAP to remote pulseaudio

Antoine Vacher antoine.vacher at tigre-bleu.net
Tue Jun 19 22:58:32 EEST 2018

Any idea someone?



----- Mail original -----
De: "Antoine Vacher" <antoine.vacher at tigre-bleu.net>
À: "ffmpeg-user" <ffmpeg-user at ffmpeg.org>
Envoyé: Jeudi 14 Juin 2018 12:39:12
Objet: [FFmpeg-user] Unable to stream SAP to remote pulseaudio


I try to stream via RTP a usb microphone from a raspberry pi with ALSA to a server with pulseaudio.

I performed a few tests but all without success. I guess it has something to do with the SAP announcements.

On the PI, I run: 
ffmpeg -f alsa -re -i pcm.usbmic -f sap sap://

On the server, if I run:
ffplay sap:// -nodisp

Then it is working.

However, if I activate the RTP plugin for pulseaudio it doesn't play.

I tried to use MiniSAPListener (https://github.com/gavv/MiniSAPListener) and it fails with:
failed to parse SDP data: invalid header

I also checked with ?same_port=1 but no success.

I guess the reason why it's not working with pulseaudio is the same reason why MiniSAPListener fails to parse the SDP data. However, I don't know how to get the raw SDP data.

Any ideas about why it's not working?


ffmpeg-user mailing list
ffmpeg-user at ffmpeg.org

To unsubscribe, visit link above, or email
ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".

More information about the ffmpeg-user mailing list