[FFmpeg-user] kmsgrab on Intel 8th generation aka h/w accelerated screen capture

robertlazarski robertlazarski at gmail.com
Mon Jun 25 04:44:17 EEST 2018

On Sun, Jun 24, 2018 at 7:10 PM, Kai Hendry <kai.hendry at gmail.com> wrote:

> Hi ffmpeg users,
> Sorry I initially posted my question here:
> https://www.reddit.com/r/ffmpeg/comments/8tgejw/kmsgrab_on_intel_8th_
> generation_aka_hw/
> Via https://trac.ffmpeg.org/wiki/Hardware/VAAPI#ScreenCapture I
> discovered kmsgrab which astonishingly doesn't seem to drop frames or
> over heat my T480s when recording my Xorg display!
> Unlike when I record with x11grab & VAAPI:
> https://github.com/kaihendry/recordmydesktop2.0/blob/vaapi/x11capture#L55
> Also see: http://lists.ffmpeg.org/pipermail/ffmpeg-user/2018-
> March/039227.html
> Same issue on ffmpeg 4.x btw:
> https://s.natalian.org/2018-06-25/1529888878.mp4.log
> However since kmsgrab requires CAP_SYS_ADMIN as it points out to its
> friendly documentation
> https://www.ffmpeg.org/ffmpeg-devices.html#kmsgrab I believe I need to
> run it with `sudo`. However when I run it as `sudo` I hit a issue
> accessing my pulseaudio microphone.
> https://stackoverflow.com/questions/51007952/recording-
> pulse-audio-as-cap-sys-admin-with-ffmpeg
> Any tips how to get this all working?
> https://github.com/kaihendry/recordmydesktop2.0/blob/kms/x11capture#L54
> is my branch of kmsgrab based screen capture cli.
> Kind regards,
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
> To unsubscribe, visit link above, or email
> ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".

That command worked for me though of course without your external dep.

Do you mean run ffmpeg as sudo? You need the proper entry in /etc/sudoers
and the ffmpeg command per sudo rules must have an absolute path like


More information about the ffmpeg-user mailing list