[FFmpeg-user] FFMPEG failing in AWS Lambda

Zaid Amir zaid.a at genie9.com
Sun Sep 2 08:49:24 EEST 2018



Static builds of FFMPEG are failing in AWS lambda. I am trying to create a
transcoding function for short videos. The function is hosted on AWS Lambda.
The problem is that AWS lambda seems to be missing something that FFMPEG
requires, at least according to Amazon.


I contacted Amazon earlier and this is their response to the issue:


"We found that the FFMPEG operations require at least libx264 and an acc
library, both of which will have dependencies of their own. To troubleshoot
the issue it will involve diving deeper into the full dependency chain. We
can see that it works in the Amazon Linux environment however, the
environment is similar but not identical to the lambda environment. There
can be some dependencies that exist in Amazon Linux but not in lambda
environment as Lambda runs on the container. Here, as FFmpeg is a third
party software, diving deeper into the dependency chain and verifying the
version compatibilities is very hard to do. Unfortunately going further,
this is bound to go into architecture and code support which is out of AWS
Support scope [1]. I hope you understand our limitations.

However should FFmpeg support have any questions specific to the Lambda
platform, please do let us know and we will be happy to assist. We will be
in better position to investigate further once you receive an update from
the FFmpeg support suggesting an issue from Lambda end."


I then went and built a dynamic ffmpeg version making sure to package all
libraries, checked ddl on each one, then made a small lambda function that
looped over all binaries and ddl each one of them, compared that to the
output I got from Amazon Linux and the same dependencies exists on both
lambda and AWS Linux yet ffmpeg still fails on lambda.



You can find a detailed log file here:


This log is generated when trying to perform an HLS transcoding on this
file: https://www.datafilehost.com/d/999a4492


Note that the issue is not related to that file alone nor is it related to
HLS, its general and happen on all videos and any ffmpeg command that tries
to seek the stream, even tried extracting a single frame from a video using
the simplest form possible  for example: 'ffmpeg -ss 00:00:02 -I file.mp4
-vframes 1 -y output.jpg' also fails with the same errors in the attached
log file.


Not sure how to debug this further. Tried enabling debug logs with
'-loglevel debug' but did not give me any extra info. Any help or




Zaid Amir


R&D Manager

T:  <tel:+96265517040> +962 6 551 7040

E:  <mailto:zaid.a at genie9.com> zaid.a at genie9.com 





 <https://www.facebook.com/ZoolzCloud>    <https://twitter.com/zoolzcloud>

W:  <https://free-email-signature.exclaimer.com/bigmind.zoolz.com>

The company accepts no liability for the content of this email, or for the
consequences of any actions taken on the basis of the information provided,
unless that information is subsequently confirmed in writing. If you are not
the intended recipient you are notified that disclosing, copying,
distributing or taking any action in reliance on the contents of this
information is strictly prohibited.



-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 4401 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20180902/efe33324/attachment.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.jpg
Type: image/jpeg
Size: 767 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20180902/efe33324/attachment.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image003.jpg
Type: image/jpeg
Size: 990 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20180902/efe33324/attachment-0001.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image004.jpg
Type: image/jpeg
Size: 839 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20180902/efe33324/attachment-0002.jpg>

More information about the ffmpeg-user mailing list