[FFmpeg-user] FFmpeg error when using "Mediacodec"

Carl Eugen Hoyos ceffmpeg at gmail.com
Wed Sep 5 13:20:05 EEST 2018

2018-09-05 12:07 GMT+02:00, Mohammed Bey Ahmed Khernache <mohbeyinfo at gmail.com>:

> ./configure
> --cross-prefix=/root/arm64-toolchains-r14b/bin/aarch64-linux-android-
> --sysroot=/root/arm64-toolchains-r14b/sysroot/ --arch=aarch64
> --target-os=android
> --extra-cflags="-I/root/libomxil-bellagio-0.9.3/include"
>  --enable-pthreads  --enable-gpl --disable-shared --enable-static
> --enable-runtime-cpudetect  --enable-hwaccels   --enable-omx  --enable-jni
> --enable-mediacodec  --enable-decoder=hevc_mediacodec

The following configure options are useless (and at least one does
not do what you think it does) and make debugging harder:

> When I tried to decode a video sequence on Android, I got the following
> error.
> ------------------------------------------------------------------------------------------------------
> shell at msm8994:/data/ffmpeg_omx_mediacodec # ./ffmpeg -vcodec
> hevc_mediacodec -i jellyfish-20-mbps-hd-hevc.mkv -f null out.null

> [amediaformat @ 0x7f8055e100] No Java virtual machine has been registered

While you can run the ffmpeg executable from an Android shell, iirc
for certain functions, it is necessary to start a Java virtual machine,
this apparently includes using mediacodec (I have never tried).

Carl Eugen

More information about the ffmpeg-user mailing list