[FFmpeg-user] Stream an encoded video content and play the URL using ffplay with decryption ket

rosmi sebastian rosmi745 at gmail.com
Mon Sep 24 15:10:58 EEST 2018

sample_enc.mp4  that I used is an encrypted file which is created using
below command:
ffmpeg -i sample.mp4 -vcodec copy -acodec copy -encryption_scheme
cenc-aes-ctr -encryption_key 76a6c65c5ea762046bd749a2e632ccbb
-encryption_kid a7e61c373e219033c21091fa607bf3b8 sample_enc.mp4

and able to play the stream_enc.mp4 with decryption key
ffplay sample_enc.mp4 -decryption_key 76a6c65c5ea762046bd749a2e632ccbb

rtsp is our final use case. I just tried on udp.
Attached the log file (ffmpeg_log) of rtsp streaming here.

Used the following commands to create the rtsp stream
ffmpeg  -re -i sample_enc.mp4 -c:v copy -c:a copy
ffserver -f /path/ffserver.conf
ffplay rtsp://localhost:5554/test.mpeg4 -decryption_key

On Mon, Sep 24, 2018 at 4:25 PM, Moritz Barsnick <barsnick at gmx.net> wrote:

> On Mon, Sep 24, 2018 at 15:35:19 +0530, rosmi sebastian wrote:
> > How to play the rtsp url created by ffmpeg for the  encrypted mp4 file
> > (download the file ,decrypt and play is not valid in our case).
> >
> > i tried the below commands
> > ffmpeg -i sample_enc.mp4 -v 0 -vcodec mpeg4 -f mpegts udp://
> >
> > ffplay udp:// -decryption_key xxxxxxxxxxxxxxxxxxxxxxxx
> udp:// is not RTSP.
> > but it failed. Plz help on this
> I don't see any error messages. Are you sure it failed?
> Your ffmpeg isn't encrypting anything, as far as I can tell, by the
> way.
> Honestly, please provide the actual command lines used (your can xxx
> out the keys or parts of the URLS) along with their complete, uncut
> console outputs, and don't use "-v 0". ffmpeg and ffplay have
> interesting messages on their console outputs which help to identify
> issues.
> Moritz
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
> To unsubscribe, visit link above, or email
> ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ffmpeg_log
Type: application/octet-stream
Size: 81108 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20180924/61834428/attachment.obj>

More information about the ffmpeg-user mailing list